systemadmin.es > LAMP y web > Instalar PHP 5.4, 5.5, 5.6 o 7.0 en Ubuntu 14.04

Instalar PHP 5.4, 5.5, 5.6 o 7.0 en Ubuntu 14.04

Vamos a ver cómo instalar las versiones 5.4, 5.5, 5.6 y 7.0 de PHP en Ubuntu 14.04

Primero deberemos tener instalado el siguiente paquete:

$ sudo apt-get install python-software-properties

Para PHP 5.4 usaremos el repositorio ppa:ondrej/php5-oldstable:

$ sudo add-apt-repository ppa:ondrej/php5-oldstable
$ sudo apt-get update
$ sudo apt-get install -y php5

Para PHP 5.5:

$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt-get update
$ sudo apt-get install -y php5.5

Para PHP 5.6

$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt-get update
$ sudo apt-get install -y php5.6

Finalmente, para PHP 7.0:

$ sudo add-apt-repository ppa:ondrej/php
$ sudo apt-get update
$ sudo apt-get install -y php7.0 

One comment to “Instalar PHP 5.4, 5.5, 5.6 o 7.0 en Ubuntu 14.04”

  1. Es más que nada curiosidad pero cual es la ventaja de instalar los paquetes frente a usar Docker.
    Un saludo

Deja un comentario:

XHTML - Tags permitidos:<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>